
SHIV SWAYAMBHU COMPUTER EDUCATION ENGLISH

QUESTION BANK OF :-  Basic Computer Course DATE :-  01/05/2018

Q.NO. OPT 1 OPT 2 OPT 3 OPT 4 ANS

1
     your presentation is ready to go but you dont know if PowerPoint is installed on the computer you will use
to present with whats the safe way

 
Save your presentation as

a web page
Set up your presentation
to be browse as a kiosk

Use the Pack and Go
wizard

All of the above 3

2      You wished to justify text over the height of paper which option will you choose

 
Page Setup from File

menu
Paragraph from Format

menu
From formatting toolbar Font from Format menu 1

3
     Youar German supplier still invoices for parts in deutsche marks. How can you have Excel convert those
sums to Euros?

 

On the Insert menu click
Symbol and from the

currency symbols subset
select the Euro sign.

On the tools menu click
Add-Ins and select the

Euro Currency Tools
check box

Apply a selected
background color

All of the above 2

4
     You were giving your presentation and you need to click a slide that?s few slides back. How do you get
there?

 

Press ESC to get back into
a normal view; click the

slide thumbnail in normal
view; then click the

resume slide show button

Press backspace until your
desired slide

Right click point to go on
the shortcut menu point
to by title and click the
slide you want to go to

All of the above 3

5      You want to track the progress of the stock market on a daily basis. Which type of chart should you use?

  Pie Chart Row Chart Line Chart Column Chart 3

6
     You want to set such that when you type Baishakh and drag the fill handle Excel should produce Jestha
Aashadh and so on. What will you set to e�ect that?

  Custom List Auto Fill Options Fill Across Worksheet Fill Series 1

7
     You need to jump to the next column breaking current column right at the cursor position. How can you
break column?

  Pressing Ctrl+Enter Pressing Alt+Shi�+Enter
Break command from

Insert menu
B and C 3

8      You have got a bunch of digital holiday photo you want to put into a slide show. What the quickest method?

 

Apply a multiple-picture
layout to several slides

and use the clipart icon on
the slides to import your

picture

On the insert menu point
to the picture click from

file and select your picture
in a group for each slide

On the insert menu point
the picture and click new

photo album
All of the above 3

9
     You have customized a design template in one presentation and you want to use it in another presentation.
What the best way to do this?

 

Use the browse feature
in the slide design task

pane to find the file that
has your design template

and apply it to the
current file.

Copy and paste the slide
with the design template
you want to include the

new presentation; inserted
slide will inherit the design

Save the presentation that
has the design template

with a new name and then
use a new file to your

presentation

All of the above 1

10      You edit an embedded table object by . .

 

Clicking the edit sub
command of the
document object

command on the edit
menu

Double clicking the table
object

Right clicking the table
object then clicking edit

document on the edit
menu

All of the above 4

11      You cannot close MS Word application by . .

 
Choosing File menu then

Exit submenu
Press Alt+F4 Click X button on title bar

From File menu choose
Close submenu

4

12      You can zoom a worksheet . . . . . .



 
With the mouse pointer in

Print Preview
With the zoom button on
the Print Preview toolbar

With the Zoom command
on the view menu

All of the above 4

13      You can use the horizontal and vertical scroll bars to . . . . . .

 
Split a worksheet into two

panes
View di�erent rows and

columns
Edit the contents of a cell View di�erent worksheets 2

14      you can use the formula palette to . . . . . .

 
Format cells containing

numbers
Create and edit formulas

containing functions
Entered assumptions data Copy a range of cells 2

15      You can use the drag and drop method to . . . . . .

  Copy cell contents Move cell contents Add cell contents A and B 4

16      You can use the format painter multiple times before you turn it o� by . . . . . .

 
You can use the format
painter button only one

time when you click it

Double clicking the
format painter button

Pressing the Ctrl key and
clicking the format painter

button

Pressing Alt key and
clicking the format painter

button
2

17      You can tell when an object is active because . . . . . .

  The object is highlighted
Eight small sizing handles

appear surrounding the
text

A box frame appears
surrounding the text

B and C 1

18      You can use drag-and-drop to embed excel worksheet data in a word document . . . . . .

 

By dragging a range of
excel data to the word
button on the taskbar
while pressing the Ctrl

key

By dragging a range of
excel data to the word
button on the taskbar

while pressing Shi� key

By dragging a range of
excel data to the word
button on the taskbar
while pressing Alt key

None of the above 1

19      You can select a single range of cells by . . . . . .

 

Clicking the upper-le� cell
in a group of cells and

then pressing the Shi� key
while clicking the lower

right cell in a group of cells

Pressing the Ctrl key while
dragging over the desired

cells

Pressing the Shi� key and
an arrow key

Dragging over the
desired cells

4

20
     You can set Excel in Automatic or Manual calculation mode. If it is in manual mode which key you will press
to update the formula values?

  F9 F5 F8 F11 1

21      You can set Page Border in Excel . . . . . .

 
From Border tab in Format

Cells dialog box
From Border tool in
Formatting toolbar

From Line Style tool in
Drawing toolbar

You can not set page
border in Excel

4

22      You can show the shortcut menu during the slide show by . . . . . .

 
Clicking the shortcut

button on the formatting
toolbar

Right clicking the current
slide

Clicking an icon on the
current slide

A and B 2

23      You can quickly change the appearance of your work by choosing Auto Format from the . . . . . . Menu.

  Edit View Format Tools 3

24      You can print only an embedded chart by . . . . . .

 
Moving the chart to a chart

sheet before you print.
Formatting the chart

before you print
Selecting the chart before

you print
A and C 4

25      You can open the Sort dialog box by choosing Sort from the . . . . . . Menu.

  View Format Tools Data 4

26      You can open the consolidate dialog box by choosing Consolidate option from the . . . . . . menu.

  Insert Format Tools Data 4



27      You can open the Highlight Changes dialog box by choosing Track Changes from the ?. Menu.

  Edit Insert Format Tools 4

28      You can open the scenario Manager dialog box by choosing scenarios from the . . . . . . menu.

  View Insert Format Tools 4

29      You can not link Excel worksheet data to a Word document

 
With the right drag

method
With a hyperlink

With the copy and paste
special commands

With the copy and paste
buttons on the standard

toolbar
4

30      You can move a sheet from one workbook into new book by

 

From Edit menu choose
Move or Copy sheet mark

the Create a ccopy and
Click OK

From Edit menu choose
Move of Copy then choose
(Move to end) and click OK

From Edit menu choose
Move or Copy then select
(new book) from To Book

list and click OK

None of the above 3

31
     You can merge the main document with data source in Excel. In mail merge operation Word is usually . . . . .
.

  Server Source Client None of the above 3

32      You can group noncontiguous worksheets with . . . . . .

 
The group button on the

standard toolbar
The shi� key and the

mouse
The ctrl key and mouse The alt+enter key 3

33      You can jump to the next column by . . . . . .

 
Clicking with your mouse

on the next column
Press Alt + Down-arrow Both of above None of the above 3

34      You can embed a organization chart in a slide by . . . . . .

 
Clicking the object

command on the edit
menu

Clicking the insert new
slide button on the

standard toolbar then
double clicking the

organization chart auto
layout

Clicking the ms
organization chart button
on the formatting toolbar

Clicking the ms
organization chart button

on the standard toolbar
2

35      You can enter which types of data into worksheet cells?

 
Labels values and

formulas
Labels and values but not

formulas
Values and formulas but

not labels
Formulas only 1

36      You can embed a MS-Organization Chart in a slide by . . . . . .

 
Clicking the object

command on the edit
menu

Clicking the object
command on the edit

menu

Clicking the insert new
slide button the standard
toolbar then double click

the organization chart
button on the formatting

toolbar

Clicking the MS-
Organization Chart button

on the standard toolbar
2

37      You can edit existing Excel data by pressing the . . . . . .

  F1 key F2 key F3 key F4 key 2

38      You can embed a Microso� Word tale in a slide by . . . . . .

 

Clicking the insert new
slide button on the

standard toolbar then
double clicking table

Clicking the insert
Microso� word table

button on the formatting
toolbar

Clicking the insert
Microso� word table

button on the standard
toolbar

A and C 4

39      You can detect spelling and grammar errors by . . . . . .

  Press Shi� + F7 Press Ctrl + F7 Press Alt+ F7 Press F7 4

40      You can edit a cell by . . . . . .



 
Clicking the formula

button
Double clicking the cell

to edit it in-place
Selecting Edit>Edit Cell

from the menu
None of the above 2

41      You can edit an embedded organization chart object by . . . . . .

  Clicking edit object
Double clicking the

organization chart object

Right clicking the chart
object then clicking edit
MS-Organizaiton Chart

object

B and C 4

42      You can copy data or formulas . . . . . .

 
With the copy paste and

cut commands on the edit
menu

With commands on a
shortcut menu

With buttons on the
standard toolbar

All of the above 4

43      You can create a new presentation by completing all of the following.

 
Clicking the new button on

the standard toolbar
Clicking file new Clicking file open Pressing ctrl + N 3

44      You can create a new presentation by completing all of the following except . . . . . .

 
Clicking the new button on

the standard toolbar
Clicking file new Clicking file open Pressing Ctrl + N 3

45      You can convert existing excel worksheet data an charts to an HTML document by using . . . . . .

  FTP wizard Internet assistant wizard Intranet wizard Import wizard 2

46      You can check the conditions against . . . . . . when applying conditional formatting.

  Cell Value Formula Both of above None of the above 3

47      You can automatically adjust the size of text in a cell if they do not fit in width by . . . . . .

 
Double clicking on the
right border of column

header

From Format choose
Columns and then Auto fit

Selection

From Format Cells dialog
box mark Shrink to fit

check box
All of the above 3

48      You can auto fit the width of column by . . . . . .

 
Double click on the

column name on column
header

Double click on the cell
pointer in worksheet

Double click on column
right border on column

header

Double click on the
column le� border of

column header
3

49      You can activate a cell by . . . . . .

  Pressing the Tab key Clicking the cell Pressing an arrow key All of the above 4

50      You can add an image to a template by clicking the Insert Picture From File button on the . . . . . . Toolbar.

  Standard Formatting Drawing Picture 4

51      You can add multiple subordinates to a position by . . . . . .

 
Clicking the subordinate
button as you press and

hold shi�

Clicking the subordinate
button each and every

time you add a
subordinate

Clicking the subordinate
button as many times as

the desired boxes
All of the above 4

52      Without using the mouse or the arrow keys what is the fastest way of getting to cell A1 in a spreadsheet?

  Press Ctrl +Home Press Home Press Shi� + Home Press Alt + Home 1

53      Why Drop Caps are used in document?

 
To drop all the capital

letters

To automatically begin
each paragraph with

capital letter

To begin a paragraph
with a large dropped
initial capital letter

None of the above 3

54      While Finding and Replacing some data in Excel which of the following statement is valid?

 
You can Find and Replace

within the sheet or
workbook

Excel does not have option
to match case for find

Both are valid None is valid 1



55      Whidh of the following allow you to select more than one slide in a presentation?

  Alt + Click each slide Shi� + drag each slide Shi� + Click each slide Ctrl + Click each slide 3

56      Which view in PowerPoint can be used to enter speaker comments?

  Normal Slide show Slide sorter Notes page view 4

57      Which types of charts can excel produce?

 
Line graphs and pie charts

only
Only line graphs

Bar charts line graphs
and pie charts

Bar charts and line graphs
only

3

58      Which types of fonts are best suitable for titles and headlines

  Serif Fonts Sans Serif Fonts Text Fonts Picture Fonts 2

59      Which type of font is best suitable for large amount of text?

  Serif Fonts Sans Serif Fonts Text Fonts Picture Fonts 1

60      Which tool you will use to join some cells and place the content at the middle of joined cell?

 
From Format Cells dialog
box click on Merge Cells

check box

From Format Cells dialog
box select the Centered

alignment

From Format Cells dialog
box choose Merge and

Center check box

Click on Merge and
Center tool on

formatting toolbar
4

61      Which tab is not available on le� panel when you open a presentation?

  Outline Slides Notes
All of the above are

available
3

62      Which symbol must all formula begin with?

  = + ( @ 1

63      Which tab in Font dialog box contains options to apply font e�ects?

  Font tab Character Spacing Text E�ects Standard Toolbar 1

64      Which short cut key inserts a new slide in current presentation?

  Ctrl+N Ctrl+M Ctrl+S All of the above 2

65      Which PowerPoint view works best for adding slide transitions?

  Slide show view Slide sorter view Slide view Notes view 2

66      Which option on the custom animation task pane allows you to apply a preset or custom motion path?

  Add e�ect Emphasis Animate now All of the above 1

67      Which option is not available in Insert Table Autofit behavior?

  Fixed Column Width AutoFit to Contents Autofit to Window Autofit to Column 4

68      Which option can be used to set custom timings for slides in a presentation?

  Slider Timings Slider Timer Rehearsal Slide Show Setup 3

69      Which option in PowerPoint allows to carry slides from one computer to another?

  Save As Save and Go Pack and Go Web and Go 3

70
     Which option can be used to create a new slide show with the current slides but presented in a di�erent
order?

  Rehearsal Custom slider show Slide show setup Slide show view 2

71      Which option allows you to select line curve freeform or scribble tools?

  Create e�ect Insert motion path Draw custom path All of the above 3

72      Which of the following can you format using buttons on the formatting toolbar?

  Your Hard Drive Format Painting Font Color Underlining 4

73      Which operation you will perform if you need to move a block of text?



  Copy and Paste Cut and Paste Paste and Delete Paste and Cut 2

74
     Which of these is a quick way to copy formatting from a selected cell to two other cells on the same
worksheet?

 

Use Ctrl to select all three
cells then click the paste
button on the standard

toolbar

Copy the selected cell then
select the other two cells
click style on the Format
menu then click Modify

Click format painter on
the Formatting toolbar
twice then click in each

cell you want to copy the
formatting to

All of the above 3

75      Which of the following you must first complete in order to delete an object?

  Double click the image Select the image Resize the image
Move the image to a new

location
2

76      Which of the following you can paste selectively using Paste Special command?

  Validation Formats Formulas All of the above 4

77      Which of the following will not set text in selected cells to italics?

 
Pressing Ctrl + I on the

keyboard
Using the Tools ? Wizard
? Web Form menu item

Using the Format ? Cells ?
Font menu item

None of the above 2

78      Which of the following will not advance the slides in a slide show view?

  The esc key The space bar The enter key The mouse button 1

79      Which of the following will not cut information?

  Pressing Ctrl + C
Selecting Edit>Cut from

the menu
Clicking the Cut button on

the standard
Pressing Ctrl+X 1

80
     Which of the following views is the best view to use when setting transition e�ects for all slides in a
presentation?

  Slide sorter view Notes page view Slide view Outline view 1

81      Which of the following tools enable you to add text to a slide without using the standard placeholders?

  Text box tool Line tool Fill color Auto shapes tool 1

82      Which of the following uses the spelling and grammar feature to indicate an incorrect spelling?

 
The incorrect word

appears in all capital
letters

The incorrect word has a
wavy red line under it

The incorrect word
appears italicized

The incorrect word
appears bold

2

83      Which of the following toolbars provide di�erent options in various master views?

  Common tasks toolbar Drawing toolbar Formatting toolbar Standard toolbar 1

84      Which of the following tool enables you to add text to a slide without using the standard placeholders?

  Text tool box Line tool Drawing tool Auto shapes tool 1

85
     Which of the following tool you will use in Excel to see what must be the value of a cell to get required
result?

  Formul Auditing Research Track Change Goal Seek 4

86
     Which of the following symbol sets would be most likely to contain a mathematical symbol such as a
degree sign greater than or equal to or a Greek letter?

  Wingdings Wingdings 3 Webdings Symbol 4

87      Which of the following statements is not true?

 

You can type text directly
into a PowerPoint slide
but typing in text box is

more convenient.

From Insert menu choose
Picture and then From File
to insert your images into

slides.

You can display a
PowerPoint presentation
in Normal Slide Sorter or

Slide Show view.

You can show or hide task
pane from View >>

Toolbars
1

88      Which of the following statement is true?

 
You can insert text boxes
from drawing toolbar in

PowerPoint

You cannot insert text
boxes from drawing

toolbar in PowerPoint

Text boxes are provides
when you choose a layout

and cant be inserted
a�erwards

None of the above 1



89      Which of the following statement is false?

 
You can set di�erent

header footer for even and
odd pages

You can set di�erent page
number formats for

di�erent sections

You can set di�erent
header footer for first page

of a section

You can set di�erent
header and footer for
last page of a section

4

90      Which of the following should you use to add shading to a drawing object on or an auto shape object?

  Text box tool Line tool Fill color B and C 4

91      which of the following should you use if you want all the slides in the presentation to have the same look?

  The slid layout option The add a slide option Outline view
A presentation design

template
4

92      Which of the following should you do to bring a bullet back to a previous level?

  Press the shi� + tab keys Press the shi� key Press the enter key Press the tab key 1

93      Which of the following should e used when you want to add a slide to an existing presentation?

  File Add a new slide Insert new slide File open File new 2

94      Which of the following should be used with the mouse when you want to draw a perfect shape?

  The Spacebar The alt key The ctrl key The shi� key 4

95      Which of the following should be used when you want to add a slide to an existing presentation?

  File Add a new slide Insert New slide File Open File New 2

96      Which of the following setup options can not be set in the page setup dialog box?

  Printer Selection
Vertical or Horizontal

Placement
Orientation Row and Column Titles 1

97      Which of the following series type is not valid for Fill Series dialog box?

  Linear Growth Autofill Time 4

98      Which of the following provides a printed copy of your presentation?

  Outline Speaker Notes Audience Handouts All of the above 3

99      Which of the following section does not exist in a slide layout?

  Titles Lists Charts Animations 4

100
     Which of the following provides a means of printing out feature notes with a miniature slide on a printed
page?

  Slide with Animation Outline View Notes page Audience handout 4

101      Which of the following position is not available for fonts on MS Word?

  Normal Raised Lowered Centered 4

102      Which of the following presentation elements can you modify using the slide master?

  Slide Comments Slide Transitions
Speaker note font and

color
All of the above 2

103      Which of the following options is not located in the Page Setup dialog box?

  Page Break Preview Page Orientation Margins Headers and Footers 1

104      Which of the following pane is not available in Task Pane?

  Getting Started Clip Art Word Art Search Results 3

105      Which of the following options is not available to remove arrows of Formula Auditing?

 
Remove all precedent

arrows
Remove all dependent

arrows
Remove all arrows

Remove all arrows for
this cell

4

106      Which of the following options changes the fill color of an object back to the default color?

  Template Automatic Patterns Fill Colors 2



107
     Which of the following options in the printer dialog box would you select to prit slides 5 and 12 in a
presentation?

  Slides Custom Shows Current Slide All 1

108      Which of the following option is not available in Insert >> Picture?

  Chart Word Art Clip Art Graph 4

109      Which of the following option is not available in Paste Special dialog box?

  Add Subtract Divide SQRT 4

110      Which of the following methods can not be used to enter data in a cell?

  Pressing an arrow key Pressing the Tab key Pressing the Esc key
Clicking on the formula

bar
3

111
     Which of the following must be used with the mouse when you want to resize an image from the center and
keep it proportioned?

  The space bar The alt key The ctrl key The shi� key 3

112      Which of the following option in File pull down menu is used to close a MS Word document?

  Quit Close Exit New 2

113      Which of the following methods can not be used to edit the contents of a cell?

  Pressing the Alt key Clicking the formula bar Pressing the F2 key Double clicking the cell 1

114      Which of the following line spacing is invalid?

  Single Double Triple Multiple 3

115      Which of the following method can insert a new slide in current presentation?

 
Right click on the Slide
panel and choose New

Slide

From Insert menu choose
New Slide

Click on New Slide button
on toolbar

All of the above 4

116      Which of the following is used to create newspaper style columns?

  Format Tabs Table Insert Table Insert Textbox Format Columns 4

117      Which of the following is/are true about rulers and guides?

 
Rulers and guides can be

turned on or o�
Rulers and guides print on

the slide
Rulers and guides help

place objects on the slide
A and C 4

118      Which of the following is the second step in creating a macro?

  Start Recording
Using your mouse or

keyboard perform the task
you want to automate

Assign a keyboard
shortcut to the macro

Give the macro a name 3

119      Which of the following is the default page setup orientation fornotes pages outlines and handouts?

  Vertical Landscape Portrait None of the above 3

120      which of the following is the default page setup orientation of slide in PowerPoint

  Vertical Landscape Portrait None of the above 2

121      Which of the following is the default page setup orientation for slides in PowerPoint?

  Vertical Landscape Portrait None of the above 2

122      Which of the following is not What IF analysis tool in Excel?

  Goal Seek Scenarios Macros None of the above 3

123      Which of the following is not valid version of MS O�ice?

  O�ice XP O�ice Vista O�ice 2007 None of the above 2

124      Which of the following is not true regarding Conditional Formatting?



 
You can add more than
one condition to check

You can set condition to
look for Bold and apply

Italics on them.

You can apply Font border
and pattern formats that

meets the specified
conditions

You can delete any
condition from

Conditional Formatting
dialog box if it is not

requried

2

125      Which of the following is not true about Find and Replace in Excel?

 
You can search for bold
and replace with italics

You can decide whether to
look for the whole word or

not

You can search in formula
too

You can search by rows
or columns or sheets

4

126      Which of the following is not the correct method of editing the cell content?

  Press the Alt key Press the F2 key Click the formula bar Double click the cell 1

127      Which of the following is not the part of standard o�ice suite?

  Word Processor Database Image Editor File Manager 4

128      Which of the following is not one of PowerPoints views?

  Slide Show View Slide View Presentation View Outline View 3

129      Which of the following is not one of the three Mail Merge Helper steps?

  Merge the two files Create the main document
Set the mailing list

parameters
Create the data source 3

130      Which of the following is not information you can specify using the solver?

  Input Cells Constraints Target Cell Changing Cells 1

131      Which of the following is not of the merge process?

 
Sort the data source

records
Format a main document Edit a data source

Merge the two files to print
or create a new document

1

132      Which of the following is not available in Font Spacing?

  Normal Loosely Condensed Expanded 2

133      Which of the following is not available on the Ruler of MS Word screen?

  Tab Stop Box Le� Indent Right Indent Center Indent 4

134      Which of the following is not an option when printing handouts?

  Six slides per page Five slides per page Three slides per page Two slides per page 2

135      Which of the following is not a worksheet design criterion?

  E�iciency Audit Ability Description Clarity 3

136      Which of the following is not an example of a value?

  350 37169 0.57 Serial Number 50771 4

137      Which of the following is not an option in the spelling dialog box?

  Edit Ignore Ignore all Change 1

138      Which of the following is not a way to cut text?

 
Select the text and press

the delete button
Select the text and select
Edit Cut from the menu

Select the text and click
the Cut button on the

toolbar

Select the text and press
Ctrl + X

1

139      Which of the following is not a way to create a new presentation?

 
Using the Scan-In Slides

feature
From scratch (create a

blank presentation
Using a template

Using the auto content
wizard

1

140      Which of the following is not a valid data type in excel

  Number Character Label Date/time 2



141      Which of the following is not a way to complete a cell entry?

  Pressing Enter
Pressing any arrow key on

the keyboard
Clicking the Enter button

on the Formula bar
Pressing spacebar 4

142      Which of the following is not a type of page margin?

  Le� Right Center Top 3

143      Which of the following is not a transition e�ect?

  Blinks Diagonal Dissolve Fade through black Blinds Vertical 1

144      Which of the following is not a part of Slide Design?

  Design Template Color Scheme Animation Scheme Slide Layout 4

145      Which of the following is not a font style?

  Bold Italics Regular Superscript 4

146      Which of the following is not a basic step in creating a worksheet?

  Save the workbook Modify the worksheet Enter text and data Copy the worksheet 4

147      Which of the following is not a feature of PowerPoint?

  Printing transparencies
Printing the speaker?s
notes along with slide

images

Linking a slide transition
with a laser pointer

Drawing with a pen 3

148      Which of the following is invalid regarding the Protection in Excel?

  Protect Sheet Protect Workbook Protect Workspace All of the above are valid 3

149      Which of the following is invalid statement?

  Sheet tabs can be colored
Some picture can be

applied as a background
of a sheet

You can set the column
width automatically fit the

amount of text

The width of a row and
be specified manually or

fit automatically
4

150      Which of the following is an example for automatic text formatting?

  Underlining Hyperlink Adjusting Extra Space
Replacing two hypens with

one hyphens
All of the above 4

151      Which of the following is graphics solution for Word Processors?

  Clipart WordArt Drop Cap All of the above 1

152      Which of the following format you can decide to apply or not in AutoFormat dialog box?

  Number Format Border Format Font Format All of the above 4

153      Which of the following function key activates the speller?

  F5 F7 F9 Shi� + F7 2

154      Which of the following includes special e�ects that can be applied to drawing objects?

  Gradient Fills Line Color and Style Rotating All of the above 4

155      Which of the following is a correct order of precedence in a formula calculation?

 
Multiplication and division
exponential positive and

negative value

Multiplication and division
positive and negative
values addition and

subtraction

Addition and subtraction
positive and negative
values exponentiation

None of the above 4

156      Which of the following is a popular DOS based spreadsheet package?

  Word Smart cell Excel Lotus 1-2-3 4

157      Which of the following is an absolute cell reference?

  !A!1 $A$1 #A#1 A1 2



158      Which of the following font e�ect is not available in PowerPoint Font dialog box?

  Underline Shadow Emboss Strikethrough 4

159      Which of the following format options should be used to display dollars on an axis?

  Normal Percentage Currency Comma 3

160      Which of the following features should you use when typing in the notes text box?

  Slide Shows Insert Slide Master Zoom 4

161      Which of the following fill e�ects can you use for the slide background?

  Gradient Texture Picture All of the above 4

162
     Which of the following features allows you to view slides in a slide show without manually advancing each
slide?

  Adding Build E�ects Setting Slide Times Adding Transitions All of the above 2

163      Which of the following feature allows you to select more than one slide in slide sorter view?

  Alt + Click Each Slide Shi� + Drag Each Slide Shi� + Click Each Slide Ctrl + Click Each Slide 3

164      Which of the following Excel screen components can NOT be turned on or o�?

  Formula Bar Status Bar Tool Bar None of the above 4

165      Which of the following describes how to select all the cells in a single column?

 
Right click on column and

select Pick from list
Use data > text to columns

menu item
Le� click on the gray
column title button

Pressing Ctrl + A on the
keyboard

3

166      Which of the following displays when an image is selected?

 
Add clip art only if it
relates to your topic

Be sure to place at least
one clipart image per slide

Resize the image so it
takes up as much space as

your text
A and B 4

167      Which of the following cannot be toggled from View >> Toolbars?

  Control Toolbox Slides Revisions Reviewing 2

168      Which of the following command is not available in Tools menu?

  Auto Text Autocorrect Auto Summarize Macro 1

169      Which of the following can NOT be used to create parallel style column?

  Format Tabs Table Insert Table Insert Textbox Format Columns 4

170      Which of the following can you use to add times to the slides in a presentation?

  Slice Show Menu Rehearse Timing Button Slide Transition Button All of the above 2

171
     Which of the following bypasses the print dialog box when printing individual slides or an entire
presentation?

  File Print Preview The Print Button File Print Ctrl + P 2

172      Which of the following can not be hidden from Tools >> Options then View tab?

  Startup Task Pane Formula Bar Status Bar Scroll Bar 4

173      Which of the following button will allow you to add delete or change records in your Data Source?

  DataSource Button Edit Button Edit DataSource Button Data Editing Button 3

174      Which of the following best describes serifs?

 
Serifs on characters help
to di�erentiate between

similar looking letters

Serifs fonts are best for
viewing test at a distance

Serifs are fine cross
strokes that appear at

the bottom and top of a
letter

Serif font are very simple
in appearance

3

175      Which of the following are types of sound files?

  LOG files DAT files WAV files DRV files 3



176      Which of the following are word processing so�ware?

  Word Perfect Easy Word MS Word All of the above 4

177      Which of the following are actions you can assign to an action button or slide object?

  Run a Macro Play a Sound Hyperlink All of the above 4

178      Which is not a data source component?

  Mail Merge Toolbar Header Row Data Fields Data Records 1

179      Which is the best view for getting your thoughts for a presentation out on the computer?

  Outline View Notes Page View Slide Sorter View Slide View 1

180      Which is used to perform what if analysis?

  Solver Goal Seek Scenario Manager All of the above 4

181      Which key deletes text before or the le� of the insertion point?

  Backspace Page Up Delete Page down 1

182      Which menu option can be used to split windows into two?

  Format > window View > window > split Window > split View > split 3

183      Which menu provides you options like Animation Scheme custom Animation Slide Transition?

  Insert Menu Format Menu Tools Menu Slide Show Menu 4

184      Which of following is Not one of Excels what-if function?

  Goal Seek Solver Scenario Manager Auto Outline 4

185
     Which of he following provides a means of printing out features notes with a miniature slide on a printed
page?

  Slides with Animation Outline View Notes Page Audience Handout 4

186      Which of the cell pointer indicate that you can move the content to other cell?

  Doctors symbol (Big Plus) Small thin plus icon
Mouse Pointer with

anchor at the tip
None of the above 3

187      Which of the cell pointer indicates that you can fill series?

  Doctors symbol (Big Plus) Small thin plus icon
Mouse Pointer with anchor

at the tip
None of the above 2

188      Which of the cell pointer indicates you that you can make selection?

 
Doctors symbol (Big

Plus)
Small thin plus icon

Mouse Pointer with anchor
at the tip

None of the above 1

189      Which of the following action removes a sheet from workbook?

 
Select the sheet then
choose Edit >> Delete

Sheet

Select the sheet then
choose Format >> Sheet

>> Hide
Both of above None of the above 1

190      Which function will you use to enter current time in a woksheet cell?

  TODAY() NOW() TIME() CurrentTIME() 2

191      Which indent marker controls all the lines except first line?

  First Line Indent Marker Le� Indent Marker Hanging Indent Marker Right Indent Marker 2

192      Which elements of worksheet can be protected from accidental modification?

  Contents Objects Scenarios All of the above 4

193      Which file format can be added to a PowerPoint show?

  .jpg .giv .wav All of the above 4



194      Which file starts MS Word?

  Winword.exe Word.exe Msword.exe Word2003.exe 1

195      Which function calculates your monthly mortage payment?

  PMT (payments) NPER (number of periods) PV (present value) All of the above 1

196      which function will calculate the number of workdays between 6/9/2004 and 8/12/2004?

  Workday Date Networkdays All of the above 4

197      Which command will you choose to convert a column of data into row?

  Cut and Paste
Edit >> Paste Special >>

Transpose
Both of above None of the above 2

198
     Which command will you use in PowerPoint if you need to change the color of di�erent objects without
changing content?

  Design Template Color Scheme Font Color Object Color 2

199      Which button do yu click to add up a series of numbers?

  The Autosum Button The Formula Button The Quicktotal Button The Total Button 1

200      Which command brings you to the first slide in your presentation?

  Next Slide Button Page Up Ctrl + Home Ctrl + End 3

201      Which command select all object at one time when selecting multiple objects to be deleted?

  Alt + A Ctrl + A Shi� + Enter Edit Select All 4

202      Which area in an excel window allows entering values and formulas?

  Title Bar Menu Bar Formula Bar Standard Toolbar 3

203      Where can you find the horizontal split bar on MS Word screen?

 
On the le� of horizontal

scroll bar
On the right of horizontal

scroll bar
On the top of vertical

scroll bar
On the bottom of vertical

scroll bar
3

204      Where can you set the shedding color for a range of cells in Excel?

 
Choose required color

form Patterns tab of
Format Cells dialog box

Choose required color on
Fill Color tool in

Formatting toolbar

Choose required color on
Fill Color tool in Drawing

toolbar
All of the above 4

205      Where can you find the Draw Table tool button?

  Standard Toolbar Formatting Toolbar Drawing Toolbar
Tables and Formatting

Toolbar
4

206      Where can you change automatic or manual calculation mode in Excel?

 
Double CAL indicator on

status bar

Go to Tools >> Options >>
Calculation and mark the

corresponding radio
button

Both of above None of the above 2

207      Where can you change the vertical alignment?

  Formatting Toolbar Paragraph Dialog Box Page Setup Dialog Box Standard Toolbar 3

208      When you work with large worksheets you may need to . . . . . .

 
Size the worksheet to fit

on the specific number of
pages

Add and remove page
breaks

Specify only certain print
areas

All of the above 4

209      When you want to insert a blank imbedded excel object in a word document you can . . . . . .

 
Click the object

command on the insert
menu

Click the o�ice links
button on the standard

toolbar

Click the create worksheet
button on the formatting

toolbar

Click the import excel
command on the file

menu
1



210
     When you start typing the same value as of some cells on same column Excel automatically shows that
text. This feature is known as . . . . . .

  AutoFill AutoCorrect AutoComplete AutoFormat 3

211      when you use the fill e�ects in the format data series dialog box you can not . . . . . .

  Rotate text on the chart Select a fore ground color Select a pattern Select a background color 1

212      When you print preview a worksheet . . . . . .

 
The entire worksheet is

displayed
The selected range is

displayed
The active portion of the
worksheet is displayed

A B and C 4

213      When you see a cell with a red triangle in the top right corner what does this signify?

  There is an error in the cell
There is a comment

associated with the cell
The font color for text in

the cell is red
A formula cannot be
entered into the cell

2

214
     When you enter Sunday and fill right Excel fill in with Monday Tuesday and so on. From where Excel knows
what to fill in next?

  AutoComplete AutoFormat Custom List Calculation Automatic 3

215      When you group worksheets . . . . . .

 
You can enter variable

data on multiple
worksheets at one time

You can print more than
one worksheet at a time

You can enter common
data formats and formulas
on multiple worksheets at

one time

B and C 4

216      When you insert an Excel file into a Word document the data are . . . . . .

  Hyperlinked Placed in a Word Table Linked Embedded 2

217      When you link data maintained in an excel workbook to a word document . . . . . .

 
The word document can

not be edit

The word document
contains a reference to

the original source
application

The word document must
contain a hyperlink

The word document
contains a copy of the

actual data
2

218      When you copy a formula . . . . . .

 
Excel erases the original

copy of the formula

Excel edits cell
references in the newly

copied formula

Excel adjusts absolute cell
references

Excel doesn?t adjust
relative cell references

2

219      When you delete a text box object from a slide in PowerPoint Presentation . . . . . .

 
The object is deleted but

text box and the text
inside is le� on the slide

The text box is deleted and
the text is pasted on the

slide

The text box and text
both are deleted

None of the above 3

220      When working in the page break preview you can . . . . . .

 
View exactly where each

page break occurs
Add or remove page

breaks
Change the print area All of the above 4

221      To play a PowerPoint show for previewing the show select . . . . . .

  View Slide Sorter View Slide View Slide Show View Outline 3

222      When the formula bar is activated you can see . . . . . .

  The Edit Formula Button The Cancel Button The Enter Button All of the above 4

223      When the formula bar is active you can see . . . . . .

  The Edit Formula button The Cancel Button The enter Button All of the above 4

224      When integrating Ms-Word and Excel Word is usually the . . . . . .

  Server Source Client None 3

225      When creating a vertical page break



  The active cell must be A1
The active cell can be

anywhere in the
worksheet

The active cell must be in
row 1

The active cell must be in
column A

3

226      When inserting Page number in footer it appeared 1 but you wish to show a. How can you do that?

 

From format menu choose
bullets and Numbering

and configure necessary
setting

From Insert menu choose
Page Number and specify

necessary setting

Click on Page Number
Format tool and specify

required setting
All of the above 3

227
     When assigning a shortcut key to a symbol you should always try to select a key or key combination that is
. . . . . .

  Unassigned
Located on the ten-key

pad section of your
keyboard.

Assigned to another task
From the same font family

as the symbol.
1

228      When all the numbers between 0 and 100 in a range should be displayed in Red Color apply . . . . . .

 
Use =if() function to
format the required

numbers red

Apply Conditional
Formatting command on

Format menu

Select the cells that
contain number between 0

and 100 then click Red
color on Text Color tool

All of the above 2

229      When an image is selected it displays which of the following?

  Two corner handles Six middle handles Eight sizing handles Six boxes 3

230      When a row of data is to be converted into columns . . . . . .

 
Copy the cells in row

select the same number of
cells in row and paste

Copy the cells in column
then choose Edit >> Paste

Special then click
Transpose and OK

Copy the cells then go to
Format >> Cells then on

Alignment tab click
Transpose check box and

click OK

Select the cells then
place the cell pointer on
new cell and choose Edit

>> Paste Special mark
Transpose check box and

click OK.

4

231      When a label is too long to fit within a worksheet cell you typically must . . . . . .

  Shorten the label
Increase the column

width
Decrease the column

width
Adjust the row height 2

232      When a range is selected how can you activate the previous cell?

  Press the Alt key Press Tab Press Enter None of the above 4

233      What is the easy way to apply varied animations to test on slides?

 
Apply e�ects in the

custom animation text
pane

Apply an animation
scheme

Customize bullets with
animated clipart

All of the above 2

234      What is the best place to find animated images for your PowerPoint 2002 presentation?

  Microso� online Word clipart PowerPoint tools and ins All of the above 2

235      What is the best way to design the layout for your slides?

 

Create layouts for slides
handouts and notes using
the Master Layout dialog
box in slide master view

For each new slide select
a layout from the Slide

Layout task pane

Apply templates from the
Slide Design task pane

None of the above 2

236      What is a quick way to extend these numbers to a longer sequence for instance 1 through 20?

 

Select both cells and
then drag the fill handle
over the range you want

for instance 18 more
rows

Select the range you want
include both cells point to
fill on the Edit menu and

then click down.

Copy the second cell click
in the cell below it on the
standard toolbar click the
down arrow on the Paste

button and then click
Paste Special

All of the above 1

237      what term describes a background that appears as a grainy non smooth surface?

  Gradient Pattern Solid Texture 1



238      What term refers to a specific set of values saved with the workbook?

  Range Scenario Trend Line What-if analysis 2

239      What will happen if you release the mouse button before releasing the shi� key when you draw a square?

 
The square will not be a

perfect square
The square will not be at

the center of the slide
The square will be smaller The square will be larger 1

240      What symbol is used before a number to make it a label?

  quote ? equal = underscore _ apostrophe 2

241      What should you do if you require pasting the same format in many places?

 
Click the Format painter

and go on pasting in many
places holding Alt Key

Double click the format
painter then go on

pasting in many places

Click the format painter
then go on pasting to

many places holding Ctrl
Key

All of the above 2

242      What PowerPoint feature will you use to apply motion e�ects to di�erent objects of a slide?

  Slide Transition Slide Design Animation Objects Animation Scheme 4

243      What lets you to create new presentation by selecting ready-made font color and graphics e�ects?

  Presentation Template Master Slide Design Template Animation Scheme 3

244
     What Pivot Table toolbar button updates the data in a Pivot Table or Pivot Chart report if the source data
has changed

  Format Report Pivot Table Refresh Data Show Detail 3

245      What is the term used when a clip art image changes the direction it faces?

  Group Flip Rotate A and B 4

246      What is the term used when you press and hold the le� mouse key and more the mouse around the slide?

  Highlighting Dragging Selecting Moving 2

247      What is the smallest width of a column?

  0 0.5 1 1.5 2

248
     What is the term used to described the separation of a clip art object into di�erent parts so that it becomes
a PowerPoint object?

  Embedding Regrouping Ungrouping Grouping 3

249      What is the short cut key to replace a data with another in sheet?

  Ctrl + R Ctrl + Shi� + R Ctrl + H Ctrl + F 3

250      What is the shortcut key you can press to create a copyright symbol?

  Alt + Ctrl + C Alt + C Ctrl + C Ctrl + Shi� + C 1

251      What is the smallest and largest font size available in Font Size tool on formatting toolbar?

  8 and 72 8 and 64 12 and 72 None of the above 1

252      What is the short cut key to open Font dialog box?

  Ctrl + F Alt + Ctrl + F Ctrl + D Ctrl + Shi� + D 3

253      What is the short cut key to open the Open dialog box?

  F12 Shi� F12 Alt + F12 Ctrl + F12 2

254      What is the maximum scale percentage available in Scale drop down box?

  500 200 100 90 2

255      What is the name of the form used to input chart values?

  Datasheet Microso� Excel Microso� Graph Auto Form 1

256      What is the purpose of inserting header and footer in document?



 
To enhance the overall

appearance of the
document

To mark the starting and
ending of page

To make large document
more readable

To allow page headers
and footers appear on

document when printed
4

257      What is the maximum font size you can apply for any character?

  163 1638 16038 None of the above 2

258      What is the maximum number of lines you can set for lines to drop box?

  3 5 10 15 3

259      What is the default font size of a new Word document based on Normal template?

  10 pt 12 pt 14 pt None of the above 2

260      What is the default font used in MS Word document?

  Times New Roman Arial Algerian Preeti 1

261      What is the default le� margin in Word 2003 document?

  1 1.25 1.5 2 2

262      What is the default number of lines to drop for drop cap?

  3 10 15 20 1

263      What is the extension of Word files?

  .msw .mp3 .doc .txt 3

264      What is the best way to create another copy of a slide?

 
Click the slide then press
Ctrl+A and paste in new

slide

From Insert Menu choose
Duplicate Slide

Redo everything on a new
slide that you had done on

previous slide
None of the above 2

265      What is place to the le� of horizontal scroll bar?

  Tab Stop Buttons View Buttons Split Buttons Indicators 2

266      What is Gutter Margin?

 
Margin that is added to the
le� margin when printing

Margin that is added to
right margin when printing

Margin that is added to
the binding side of page

when printing

Margin that is added to the
outside of the page when

printing
3

267      What is an expression that tells how the numbers in a determined set of cells are to be calculated?

  Formula Field Data Query Correct Answer: 1

268      What is defined by the handout master?

  Slide Formatting
Layout of audience

handout notes

Handout content
formatting for Microso�

word export
All of the above 2

269      What is a slide-title master pair?

 
The title area and text area

of a specific slide

A slide master and title
master merged into a

single slide

A slide master and title
master for a specific

design template
All of the above 3

270      What is a portion of a document in which you set certain page formatting options?

  Page Document Section Page Setup 3

271      What is a motion path?

 
A type of animation

entrance e�ect
A method of advancing

slides
A method of moving

items on a slide
All of the above 3

272      What happens when you press Ctrl + X a�er selecting some cells in Excel?



 

The cell content of
selected cells disappear
from cell and stored in

clipboard

The cells selected are
marked for cutting

The selected cells are
deleted and the cells are

shi�ed le�

The selected cells are
deleted and cells are

shi�ed up
2

273      What happens when you click on Insert >> Picture >> Clip Art

 
It inserts a clipart picture

into document
It lets you choose clipart
to insert into document

It opens Clip Art taskbar None of the above 3

274      What happens if you press Ctrl + Shi� + F8?

 
It activates extended

selection
It activates the

rectangular selection
It selects the paragraph on
which the insertion line is.

None of the above 2

275      What happens if you remove the check mark from Row & Column headers on Options dialog box?

 
This will remove row

headings and column
headings of your data

This will remove the
column headings A B C

This will remove row and
column heading of chart

This will remove row and
column heading of table

2

276      What happens if you select first and second slide and then click on New Slide button on toolbar?

 
A new slide is inserted as
first slide in presentation

A new slide is inserted as
second slide in

presentation

A new slide is inserted as
third slide in
presentation

None of the above 3

277      What happens if you edited an image inserted in PowerPoint?

 
The original file that was
inserted is not changed

The original file that was
inserted is changed

The original file is changed
when you save
presentation

None of the above 1

278      What happens if you mark on Hidden check box of Font dialog box a�er you select some text?

 

The text is deleted from
document and you need

to bring from Recycle Bin if
required again.

The text is hidden and
you need to bring it by

removing the check box
if needed again

The text is deleted and
cannot be returned back

The text is hidden and
cannot be returned back

2

279      What feature will you use to apply motion e�ects in between a slide exits and another enters?

  Slide Transition Slide Design Animation Objects Animation Scheme 1

280      What function displays row data in a column or column data in a row?

  Hyperlink Index Transpose Rows 3

281      What does the VLOOKUP function do?

 
Looks up text that contain

V

Checks whether text is the
same in one cell as in the

next
Finds related records All of the above 3

282
     What feature enables you to adjust or back solve the value in a cell to reach a desired outcome in a
formula?

  Goal Seek Scenario Summary Report Forecasting Trend Line 4

283      What does Ctrl + = key e�ect in MS Word?

  Superscript Subscript All Caps Shadow 2

284      What does EXT indicator on status bar of MS Word indicate?

 
It indicates whether the

external text is pasted on
document or not

It indicates whether
extended add-ons are

installed on MS Word or
not

It indicates whether
Extended Selection

mode is turned on or o�
None of the above 3

285
     What do we call a computer program that organizes data in rows and columns of cells? You might use this
type of program to keep a record of the money you earned moving lawns over the summer.

  Spreadsheet Program Database Program Word Processor Program
Desktop Publisher

Program
1

286      What are symbols used to identify items in a list?

  Icons Markers Bullets Graphics 3



287      What are the three options available in Insert >> Picture menu?

  Clipart Pictures Shapes Clipart From File Shapes
Clipart From Files

AutoShapes
Clipart Pictures

AutoShapes
3

288      Weight refers to . . . . . .

 
The print density of

characters
The height of the printed

character
Upright or slanted shape

The design and
appearance of characters

1

289      What are lines curve freeform and scribble?

 
Emphasis e�ects that can
be applied to animations

Types of custom motion
paths

Predefined entrance and
exit e�ects

All of the above 2

290      Want a PowerPoint photo album slide show to play continuously?

 
Use random slide

transitions
Launch an online

broadcast
Loop continuously All of the above 1

291      Want your logo in the same position on every slide automatically? Insert it on the . . . . . .

  Handout Master Notes Master Slide Master All of the above 3

292      We can replace a font on all slides with another font using the . . . . . . option

  Edit Fonts Tools Fonts Tools Replace Fonts Format Replace Fonts 4

293      Using a custom animation e�ect how do you make text appear on a slide by letter?

 
Apply the animation

scheme fade in one by one

Apply an entrance e�ect
and then set it to by

letter in the e�ect option
dialog box

Apply the fly in entrance to
the text and then set its

speed to very slow
All of the above 2

294
     Uppercase on Change Case dialog box and All Caps on Fonts dialog box both converts selected text into
Capital Letters. What is the di�erence between the two?

 
Both are same. They are

only two di�erent ways of
capitalize text.

It is faster to convert from
Change Case than from

Font dialog box

Change Case makes
conversion permanent

but All Caps on Font can
always be reverted

All Caps on Font dialog
box makes the change

permanent where Change
Case can be always

reverted

3

295      To view a cell comment . . . . . .

 
Click the edit comment
command on the insert

menu

Click the display comment
command on the window

menu

Position the mouse
pointer over the cell

Click the comment
command on the view

menu
3

296      To start slide show of a presentation . . . . . .

  Hit F5 key
From Slide Show menu

choose View Show option
From Slide Show menu
choose Rehearse timing

A and B 4

297      To select one hyperlink a�er another during a slide presentation what do you press?

  Tab Ctrl + K Ctrl + H All of the above 1

298      To start Microso� PowerPoint application . . . . . .

 
Click on Start >> Programs

>> All Programs >>
Microso� PowerPoint

Hit Ctrl + R then type
ppoint.exe and Enter

Click Start >> Run then
type powerpnt then

press Enter
All of the above 3

299      To save a workbook you . . . . . .

 
Click the save button on

the standard toolbar
from the menu

Press Ctrl+F5
Click Save on the Windows

Start button
Select Edit>Save 1

300      To select all of the boxes of an organization chart . . . . . .

 
Click and edit and select

all

Right click the chart
background and then click

select all

Press and hgold the SHIFT
key and click each box

All of the above 4



301      To remove the content of selected cells you must issue . . . . . . Command.

  Edit >> Delete Edit >> Clear >> Contents Edit >> Clear >> All Data >> Delete 2

302      To protect a worksheet you can choose Protection and the Protect Sheet from the . . . . . . Menu.

  Edit Format Tools Data 3

303      To preview a motion path e�ect using the custom animation task pane you should . . . . . .

  Click the play button
Click the show e�ect

button
Double click the motion

path
All of the above 1

304      To open Columns dialog box quickly . . . . . .

 
Double click on the le�

margin area of ruler
Double click the space
between area on ruler

Double click the right
margin in ruler

All of the above 2

305      To move the cursor page to page of document use . . . . . .

  Ctrl+PgDn Ctrl+PgUp Both of above None of the above 3

306
     To make a selection of slides on our presentation use a di�erent design template from the other slides
what do you do?

 

Select the slides
thumbnails in that section
and apply a di�erent color

scheme

Select the slide
thumbnails in that
section and apply a

di�erent design
template

Select one of the slide in
the section you want to
change customize the

fonts and colors and use
the format painter tool to
apply those styles to the

other slides in the section

All of the above 2

307      To maintain the perspective (height and width ratio) of an object when resizing you need to . . . . . .

 
Press and hold the shi�

key while dragging a
corner sizing handle

Press and hold the alt +
ctrl keys while dragging a

middle handle

Drag a corner sizing
handle

A and C 1

308      To insert slide numbers . . . . . .

 
Insert a text box and select

Insert >> Page Number

Insert a textbox and select
Insert >> Number >>

PageNumber

Choose Insert >> Slide
Number

Insert a new text box and
select Insert >> slide

Number
4

309      To insert three columns between columns D and E you would . . . . . .

  Select column D Select column E Select columns E F and G Select columns D E and F 2

310      To insert a drop cap in one of the paragraph you should access . . . . . .

  Insert Menu Format Tools None of the above 2

311      To insert a hyperlink in a slide . . . . . .

  Choose Insert >> Hyperlink Press Ctrl + K
Hyperlinks cant be
inserted in slides

A and B 4

312      To insert a new slide in the current presentation we can choose . . . . . .

  Ctrl + M Ctrl + N Ctrl + O Ctrl + F 1

313      To import text from a word document that uses headings into a PowerPoint presentation . . . . . .

 
This can not be done in

PowerPoint
Click Insert Slides from

Outline
Click Import Word

Document Headings

Click File New
Presentation from Word

Headings
2

314
     To hold row and column titles in place so that they do not scroll when you scroll a worksheet click the . . . . .
.

 
Unfreeze panes command

on the window menu
Freeze panes command

on the window menu
Hold titles command on

the edit menu
Split command on the

window menu
2

315      To give a PowerPoint presentation to a large audience you . . . . . .



 
Set up your computer in a
large auditorium and click

large auditorium OK

Click the slide you wish
the audience to see in

normal view then click the
next slide and so on.

Choose either view slide
show or slide show view

show
Slick slide show OK 3

316      To get to the Symbol dialog box click on the . . . . . . Menu.

  Insert Format Tools Table 1

317      To edit the text within the boxes of an organization chart you . . . . . .

 
Select the box and text

then make changes
Select the box then make

the dchanges
Highlight the text them

make the changes
A and B both 1

318      To exit the PowerPoint . . . . . .

 
Click the application

minimize button
Click the document close

button

Double click the
applications control

menu icon

Double click the document
control menu icon

3

319      To edit in an embedded excel worksheet object in a word document . . . . . .

 
Use the excel menu bar
and toolbars inside the

word application
Edit the hyperlink

Edit the data in a excel
source application

Use the word menu bar
and toolbars

1

320      To edit data in an embedded Excel worksheet object in a Word document . . . . . .

 
Use the Excel menu bar
and toolbars inside the

word application
Edit the hyperlink

Edit the data in a Excel
source application

Use the Word menu bar
and toolbars

1

321      To drag a selected range of data to another worksheet in the same workbook use the . . . . . .

  Tab Key Alt Key Shi� Key Ctrl Key 4

322      To create an interactive Pivot Table for the web you use a Microso� O�ice Web component called . . . . . .

  HTML Pivot Table Field List Pivot Table List Pivot Table Report 4

323      To delete an embedded objects first . . . . . .

  Double click the object
Select the object by

clicking it
Press the Shi� + Delete

keys
Select it and then press

the delete key
4

324      To create a formula you first . . . . . .

 
Select the cell you want

to place the formula into

Type the equals sign (=) to
tell Excel that you are

about to enter a formula

Enter the formula using
any input values and the

appropriate mathematical
operators that make up

your formula

Choose the new command
from the file menu

1

325      To create a PowerPoint presentation from a template . . . . . .

 
Click File New select the

presentations tab and
choose a template

Click File New Template
and choose a template

Import a presentation
template from

PowerPoints template
wizard

Click Create Template
from scratch Now

1

326      To create a formula you can use . . . . . .

 
Values but not cell

references
Cell references but not

values

Values or cell references
although not both at the

same time
Value and cell references 4

327      To change font size of a selected slide title you . . . . . .

 
Click the toolbars Font
dropdown arrow and

choose the font you prefer

Click Format Title and
choose a font from the

font tab

Click the toolbars
Increase Font Size button

Click Title New Font OK 3

328      To copy cell contents using drag and drop press the

  End Key Shi� Key Esc Key None of the above 4



329      To copy formatting from one area in a worksheet and apply it to another area you would use . . . . . .

 

The Edit>Copy Format and
Edit>Paste Format

commands form the
menu.

The Copy and Apply
Formatting dialog box

located under the
Format>Copy and Apply

menu.

There is no way to copy
and apply formatting in
Excel ? You have to do it

manually

The Format Painter
button on the standard

toolbar
4

330      To center worksheet titles across a range of cells you must . . . . . .

 

Select the cells
containing the title text

plus the range over
which the title text is to

be centered

Widen the columns

Select the cells containing
the title text plus the range
over which the title text is

to be enfettered

Format the cells with the
comma style

1

331      To apply Goal Seek command your cell pointer must be in . . . . . .

 
The Changing cell whose

value you need to find
The Result Cell where

formula is entered
The cell where your

targeted value is entered
None of the above 2

332      To autofit the width of column . . . . . .

 
Double click the right

border of column
Double click the le�

border of column
Double click the column

header
All of the above 1

333      To adjust the width of table columns you . . . . . .

 
Click table menu. Column

width then make
adjustments

Drag the vertical gridline
between two columns

Drag the column markers
on the table ruler bar

B and C 4

334      This type of so�ware is similar to an accountants worksheet

  Word Processing Database Spreadsheets Graphics 3

335      To activate the previous cell in a pre-selected range press . . . . . .

  Alt key Tab key Enter key None of the above 4

336      To add a header or footer to your handout you can use . . . . . .

  The Title Master The Slide Master The Handout Master All of the above 3

337      To add a new row to a table you would . . . . . .

 
Click the insert rows

command on the insert
menu

Press the enter key
Click the insert rows

button on the standard
toolbar

None of the above 4

338
     There can be many ways to insert page number in a document. Which of the following lets you insert page
number . . . . . .

 
Page number from Insert

menu
Page Setup from file menu

Footnote from Insert
menu

A and C 1

339      Thesaurus tool in MS Word is used for . . . . . .

  Spelling Suggestions Grammar Options
Synonyms and Antonyms

words
All of the above 3

340
     The view that displays the slides of a presentation as miniature representations of the slides is called . . . . .
.

  Slide Show Slide Sorter View Notes Page View Outline View 2

341      The Trace Precedence on Auditing shows . . . . . .

 
Which cells are used in

current formula
In which formula the

current cell is used

Which cells are used in this
formula and in which

formula this cell is used
None of the above 1

342      The Trace Dependence in auditing shows . . . . . .

 
Which cells are used in

current formula
In which formula the

current cell is used

Which cells are used in this
formula and in which

formula this cell is used
None of the above 2



343      The spelling tool is placed on . . . . . . Toolbar.

  Standard Formatting Drawing Reviewing 4

344      The toolbars that are displayed by default in the PowerPoint window includes . . . . . .

 
Menu bar standard toolbar

formatting toolbar
drawing toolbar status bar

Menu bar standard
toolbar formatting

toolbar drawing toolbar
status bar

Standard toolbar
formatting toolbar

drawing toolbar status bar

Menu bar standard toolbar
status bar drawing toolbar

2

345      The slide that is used to introduce a topic and set the tone for the presentation is called the . . . . . .

  Table Slide Graph Slide Bullet Slide Title Slide 4

346      The size of the organization chart object is . . . . . .

 
Determined by the

presentation design and
can not be changed

Determined by the
presentation design but

can be changed in
PowerPoint

Dependent on the amount
of text within the

organization chart
B and C 4

347      The size of a table object is . . . . . .

 
Dependent on the amount

of text within the table

Determined by the
presentation design but

can be changed

Determined by the
presentation design and

can not be changed
A and C 2

348      The power point view that displays only text (title and bullets) is . . . . . .

  Slide Show Slide Sorter View Notes Page View Outline View 4

349      The quickest way to create a PowerPoint presentation is to use the . . . . . .

 
Word for windows

templates
Auto creation wizard Auto content wizard Presentation wizard 3

350      The selected design template can be applied to . . . . . .

  Current slide only All the slides
All the new presentation

you create
All of the above 4

351      The short cut key Ctrl + R is used in Excel to . . . . . .

 
Right align the content of

cell
Remove the cell contents

of selected cells
Fill the selection with

active cells to the right
None of the above 3

352      The Paste Special command lets you copy and paste . . . . . .

 
Multiply the selection by a

copied value
Cell comments Formatting options

The resulting values of a
formula instead of the

actual formula
4

353      The Name box . . . . . .

 
Shows the location of the

previously active cell
Appears t the le� of the

formula bar
Appears below the status

bar
Appears below the menu

bar
2

354      The Name box on to the le� of formula bar . . . . . .

 
Shows the name of
workbook currently

working on

Shows the name of
worksheet currently

working on

Shows the name of cell
or range currently

working on
None of the above 3

355
     The numbers in our worksheet look like this: 1000. You want them to look like this: $1 000.00. How can you
accomplish this?

  None of these
Select Format > Money

from the menu

Click the Currency Style
button on the formatting

toolbar

You have to retype
everything and manually

add the dollar signs
commas and decimals.

3

356      The maximum zoom percentage in Microso� PowerPoint is . . . . . .

  1 2 4 5 3

357      The Microso� clip gallery allows you to . . . . . .



 
Add word art images to a

slide
Spell check your

presentation
Add clip art images to a

slide or slides
Add slides to a
presentation

3

358      The minimum and maximum value you can set for Save AutoRecovery Info in Excel are . . . . . .

  1 and 120 minutes 0 and 120 minutes 2 and 60 minutes 1 and 10 minutes 1

359      The minimum number of rows and columns in MS Word document is . . . . . .

  1 and 1 2 and 1 2 and 2 None of the above 1

360      The keystrokes Ctrl + I is used to . . . . . .

  Increase font size Inserts a line break
Indicate the text should be

bold
Applies italic format to

selected text
4

361      The handout master contains placeholders from all of the following except . . . . . .

  Slide Number Title Footer Header 2

362      The key F12 opens . . . . . .

  Save As dialog box Open dialog box Save dialog box Close dialog box 1

363
     The feature of Word that automatically adjusts the amount of space between certain combination of
characters so that an entire word looks more evenly spaced. What is that feature called?

  Spacing Scaling Kerning Positioning 3

364      The e�ect applied to display when slides changes in slide show view is . . . . . .

  Slide Animation Custom Animation Custom Transition Slide Transition 4

365      The Delete key of keyboard is assigned to which command in Excel?

  Edit >> Clear >> Contents Edit >> Clear >> All Edit >> Delete All of the above 1

366      The di�erence between Slide Design and Auto Content Wizard is . . . . . .

  Both are same
AutoContent Wizard is just
the wizard version of Slide

Design

Slide Design does not
provide sample content
but Auto Content Wizard
provides sample content

too!

Slide Design asks your
choice in steps but Auto
Content Wizard does not

let you make choices

3

367      The default font used in Excel is . . . . . .

  Arial Algerial Times New Roman Preeti 1

368      The default header for a worksheet is . . . . . .

  Your name The date and time None The sheet tab name 3

369      The default font size in Excel worksheet is . . . . . .

  10 points 12 points 14 points None of the above 1

370      The default and maximum number of sheets for a new workbook in Excel 2003 is . . . . . .

  3 and 255 3 and 256 1 and 255 1 and 256 2

371      The command Edit >> Fill Across Worksheet is active only when . . . . . .

  One sheet is selected
When many sheets are

selected
When no sheet is selected None of the above 2

372      The chart wizard term data series refers to . . . . . .

  A chart legend
A collection of chart data

markers
A set of values you plot in

a chart
A data label 2

373      The boxes that are displayed to indicate that the text pictures or objects are placed in it is called ?

  Placeholder Auto text Text box Word art 1

374      The cell reference for a range of cells that starts in cell B1 and goes over to column G and down to row 10 is?

  G1-G10 B1.G10 B1;G10 B1:G10 4



375      The autofill feature . . . . . .

 
Extends a sequential

series of data
Automatically adds a

range of cell values
Applies a boarder around

selected cells
None of the above 1

376      The best way to insert a new slide in a presentation is to use the . . . . . .

  Normal View Special View Slide Show View Slide Sorter View 4

377      The auto shapes tool provides you with . . . . . .

 
Fancy text to place on your

slide
Commonly found shapes

Any shape you want to
add on a slide

Clip art that is related to
your presentation

2

378      The auto calculate feature . . . . . .

 
Can only add values in a

range of cells

Provides a quick way to
view the result of an

arithmetic operation on
a range of cells

Automatically creates
formulas and adds them

to a worksheet
A and C 2

379      The arrangement of elements such as Title and Subtitle text pictures tables etc. is called as . . . . . .

  Layout Presentation Design Scheme 1

380      The arrows created by Auditing can be removed by . . . . . .

 
Clicking on the arrow and

press Delete

Clicking on Remove All
arrows on Formula

Auditing toolbar
Both of above None of the above 2

381      Text boundary can be displayed or hidden from . . . . . .

 
Auto text option from

Insert menu
Customize from Tools

menu
All of above Options from Tools menu 4

382      Text formulas . . . . . .

  Replace cell references
Return ASCII values of

characters
Concatenate and
manipulate text

Show formula error value 3

383      The Chart wizard term data categories refers to . . . . . .

  A chart plot area A horizontal axis
The organization of

individual values with a
chart?s data series

The data range that supply
chart data

2

384      Tab scroll buttons are place on Excel screen . . . . . .

 
Towards the bottom right

corner
Towards the bottom le�

corner
Towards the top right

corner
Towards the top le� corner 2

385      Tab scrolling button . . . . . .

 
Allows you to view a
di�erent worksheet

Allows you to view
additional worksheet rows

down

Allows you to view
additional worksheet
columns to the right

Allows you to view
additional sheets tabs

4

386
     Suppose you wanted to create an AutoCorrect entry that would type the words We regret to inform you
that your submission has been declined Of the following choices which would be the best name you could
assign to this entry?

  Regret Subdual
We regret to inform you

that your submission has
been declined

11 2

387      Status indicators are located on the . . . . . .

  Vertical Scroll Bar Horizontal Scroll Bar Formula Bar Formatting Toolbar 3

388      Superscript subscript outline emboss engrave are known as . . . . . .

  Font Styles Font E�ects Word Art Text E�ects 2

389      special e�ects used to introduce slides in a presentation are called . . . . . .

  E�ects Custom Animations Transitions Present Animations 3



390      Shimmer Sparkle text Blinking Background etc. are known as . . . . . .

  Font Styles Font E�ects Word Art Text E�ects 4

391      Slide show options available to the presenter include all of the following except . . . . . .

  Transitions Command Speaker notes command Meeting minder command Navigation Commands 1

392      Special category of Number tab in Format Cells dialog box can be used to apply formats like . . . . . .

  Zip Code Phone Number Both of above None of the above 3

393      Right clicking something in PowerPoint . . . . . .

  Deletes the object Selects the object
Opens a shortcut menu

listing for the object
Nothing he right mouse

button for operation
3

394      Rounding errors can occur . . . . . .

 

When you use
multiplication division or

exponentiation in a
formula

When you use addition
and subtraction in a

formula

Because Excel uses hidden
decimal places in

computation

When you show the results
of formulas with di�erent
decimal places than the

calculated results

1

395      Pressing F8 key for three times selects . . . . . .

  A word A sentence A paragraph Entire document 2

396      Right clicking something in Excel . . . . . .

  Deletes the object
Nothing the right mouse

button is there for le�
handed people

Opens a shortcut menu
listing everything you

can do to the object
Selects the object 3

397      Press animation e�ects allows you to . .

 
Add clip art images to your

slides
Create a custom transition

to the nect slide
Show bullet items as

they are discussed
None of the above 3

398      Presentation designs regulate the formatting and layout for the slide and are commonly called . .

  Design plates Templates Placeholders Blueprints 2

399      Pre-made sheet formats like Simple Classic Accounting Colorful etc. can be applied from . . . . . .

  from Fromat >> Cells
from Format >>

Autoformat
from Table >> Autoformat All of the above 2

400      PowerPoint presentations are widely used as . . . . . .

  Note outlines for teachers
Project presentations by

students
Communication of

planning
All of the above 4

401
     Paper spreadsheets can have all the same advantages as an electronic spreadsheet except which of the
following?

  Rows and columns Headings Speed None of the above 3

402      Paste Special allows some operation while you paste to new cell. Which of the following operation is valid?

  Square Percentage Goal Seek Divide 4

403      Portrait and Landscape are . . . . . .

  Page Orientation Paper Size Page Layout All of the above 1

404      PowerPoint 2000 has . . . . . . Number of views.

  3 4 5 6 1

405      PowerPoint can display data from which of the following add-in so�ware of MS-O�ice?

  Equation Editor Organization Chart Photo Album All of the above 4

406      One way to make a PowerPoint slide display animations is to . . . . . .



 
Select the slide in normal

view; and click Format
Animation

Click the PowerPoint
window and move it

around vigorously with the
mouse for a manual

animation e�ect

Select the slide in slide
sorter view right click

and choose preset
animations from the

shortcut menu

PowerPoint does not have
an animation feature

3

407      Common tasks button allows you to do . . . . . .

 
Apply a design template to

a slide
Insert a new slide

Choose a new layout for a
slide

All of the above 4

408      On which toolbar can you find Format Painter tool?

  Standard toolbar Formatting toolbar Drawing Toolbar Picture Toolbar 1

409      Multiple calculations can be made in a single formula using . . . . . .

  Standard Formulas Array Formula Complex Formulas Smart Formula 2

410      Objects on the slide that hold text are called . . . . . .

  Placeholders Object holders Auto layouts Text holders 1

411      On which part of the chart are the values entered in a data sheet displayed?

  The title area The legend The y-axis The x-axis 3

412      MS O�ice provides help in many ways which of these is one of them?

  What is this? O�ice Assistant Help menu All of the above 4

413      Microso� PowerPoint is a . . . . . .

  Database Program Spreadsheet Program Presentation Program Word Processing Program 3

414      MS Excel provides this as the default value for step in Fill Series dialog box.

  0 1 5 10 2

415      Maximum Zoom Percentage in Excel is . . . . . .

  10 100 300 400 4

416      Merge cells option can be applied from . . . . . .

 
Format Cells dialog box

Alignment Tab
Formatting toolbar Both of above None of the above 1

417      Long text can be broken down into many lines within a cell. You can do this through . . . . . .

 
Wrap Text in Format >>

Cells
Justify in Edit >> Cells

Text Wrapping in Format
>> Cells Layout tab

All of the above 1

418      Macros are run or executed from the . . . . . . menu.

  Insert Format Tools Data 3

419      Material consisting of text and numbers is best presented as . . . . . .

  A table slide A bullet slide A title slide All of the above 1

420      Line spacing refers to . . . . . .

 
The space between the

lines of text
The height of the line The length of the line A and C 1

421      List Box and Text box . . . . . .

 
Are some other than that

in a list box the bullets
are enabled

Are di�erent. List boxes
are used to present lists

and cant be created with
text boxes.

Both of above None of the above 1

422      It is possible to . . . . . . a data source before performing a merge.

  Create Modify Sort All of the above 4



423      In Word the mailing list is known as the . . . . . .

  Data Sheet Source Data Source Sheet 3

424      It is acceptable to let long text flow into adjacent cells on a worksheet when . . . . . .

 
Data will be entered in the

adjacent cells
No data will be entered

in the adjacent cells
There is nt suitable

abbreviation of the text
Tehere is not time to

format the next
2

425      In which menu can you find features like Slide Design Slide Layout etc.?

  Insert Menu Format Menu Tools Menu Slide Show Menu 2

426      In order to edit a chart you can . . . . . .

 
Triple click the chart

object
Click and drag the chart

object
Double click the chart

object
Click the chart object 3

427      In slide layout panel how many layouts are available for text layout by default?

  4 7 12 None of the above 1

428      In the context of animations what is a trigger?

 
An action button that

advances to the next slide

An item on the slide that
performs an action when

clicked

The name of a motion
path

All of the above 2

429      In normal view how can you quickly change to handout master view?

 
Click the outline tab and
select handout master

view

Press the shi� key and
click the handout master

view button

On the view menu click
slide sorter and click

handouts.
All of the above 2

430      In notes master view how do you modify the font size of text for all the notes of a presentation?

  Modify the slide design
Modify the notes master

layout
Modify the text within
the body placeholder

All of the above 3

431      In Microso� PowerPoint the entry e�ect as one slide replaces another in a show is called a (an) . . . . . .

  animation slide transition custom animation preset animation 2

432      In Microso� PowerPoint two kind of sound e�ects files that can be added to the presentation are

  .wav files and .mid files .wav files and .gif files .wav files and .jpg files .jpg files and .gif files 1

433      In Microso� PowerPoint in order to see all the slides on one screen use . . . . . .

  view slide sorter view slide view master view slide show 1

434      In a PowerPoint presentation . . . . . .

 
Sound clips can be

inserted but not movie
clips

Movie clips can be inserted
but not sound clips

Both cannot be inserted Both can be inserted 4

435      In a worksheet you can select . . . . . .

  The entire worksheet Rows Columns A B and C 4

436      In a document what is the maximum number of columns that can be inserted in MS Word Table?

  35 15 63 65 3

437      If you want to keep track of di�erent editions of a document which features will you use?

  Editions Versions Track Change All of the above 2

438
     If you will be displaying or printing your document on another computer youll want to make sure and
select the . . . . . . option under the Save tab.

  Embed Fonts Embed True Type Fonts Save True Type Fonts Save Fonts 2

439      If you want to insert some slides from other presentation into current one choose . . . . . .

 
From Insert menu choose

Slides from Files
From Insert menu choose
Slides from Presentation

From Insert menu choose
Slides

None of the above 1



440      If you select Insert >> Picture >> From File

 
You can insert pictures

and ClipArts
You can insert ClipArts

only
You can insert pictures

only
None of the above 3

441      If you want to convert a symbol or several lines of text into an AutoCorrect entry you should . . . . . .

 

Insert the symbol or type
the text in a Word

document first. Then
select the text or symbol

and go to the
AutoCorrect dialog box.

Click the Tools menu and
choose AutoCorrect

Options. Then click the
Insert menu and choose

Symbol (or click the
Format menu and choose

Paragraph) to add the
symbol or paragraph to

AutoCorrect.

AutoCorrect can only
accommodate one line of
text. It is not possible to

convert a symbol or
multiple lines of text into

an AutoCorrect entry.

Insert the symbol or type
the text in a Word

document first. Then
select the text or symbol
and click the Edit menu

followed by Paste Special.
Select New AutoCorrect
Entry and then click OK.

1

442      If you press . . . . . . the cell accepts your typing as its contents.

  Enter Ctrl + Enter TAB Insert 1

443
     If you need to remove only the formatting done in a range (numbers and formula typed there should not be
removed) you must . . . . . .

 
From Edit menu choose
Clear and then Formats

From Edit menu choose
Delete

Click on Remove
Formatting tool on
Standard Toolbar

Double click the Format
Painter and then press Esc

key in keyboard
1

444      If you need to hide some paragraphs how can you do it?

 
From Paragraph dialog

box
From Font dialog box From Options Dialog box None of the above 2

445      If you need to double underline a word how will you do that?

 

Go to Format menu and
then Font option. Open

Underline Style and
choose Double Underline

From Format menu
choose Font option and
then from Font tab open

Underline Style and select
Double Underline

Select the text then
choose Format >> Font
and on Font tab open
Underline Style and

choose Double Underline

Click double underline
tool on formatting toolbar

3

446      If you need to change the typeface of a document which menu will you choose?

  Edit View Format Tools 3

447      If you need a text to show vertically in a cell. How will you achieve this?

 
Choose Vertical on Text

alignment in Format Cells
dialog box

Choose 90 Degrees in
Orientation of Format

Cells dialog box

Choose Distributed from
the Vertical drop down list
of Format Cells dialog box

Choose Center Across
Selection from Horizontal
combo box in Format Cells

dialog box

2

448
     If you have a PowerPoint show you created and want to send using email to another teacher you can add
the show to your email message as . . . . . .

  Inclusion Attachment Reply Forward 2

449
     If you begin typing an entry into a cell and then realize that you don?t want your entry placed into a cell
you:

  Press the Erase key Press Esc Press the Enter button
Press the Edit Formula

button
2

450
     If you are working in English (US) Chinese or Japanese Excel 2002 can speak data as you enter it to help you
verify accuracy. How do you activate this feature?

 

Point to speech on the
tools menu and then

click show text to speech
toolbar

Click validation on the
data menu

Point to speech on the
tools menu and then click

speech recognition
All of the above 1

451      Hyperlinks can be . . . . . .

  Text Drawing objects Pictures All of the above 4

452      Hyperlinks cannot be . . . . . .

 
Special shapes like stars

and banners
Drawing objects like

rectangles ovals
Pictures All can be hyperlinks 4



453      If the number of columns is selected 1 and the line between check box is marked where is the line drawn?

  In the le� margin In the right margin
Both in le� and right

margin
None of the above 4

454      How should you print a selected area of a worksheet if youll want to print a di�erent area next time?

 
On the file menu point to
print area and then click

set print area.

On the file menu click
print and then click

selection under print
what

On the view menu click
custom views then click

add
All of the above 2

455      How would you create the diagram in PowerPoint?

 
Use auto shapes and the
drawing toolbar to create
the diagram and design it

Open the diagram gallery
from the drawing toolbar
and choose this diagram

type

Use the chart command
on the insert menu to

import the diagram
All of the above 2

456      How much space in minimum must be provided between columns?

  0 0.5 1 1.5 1

457      How should you print a selected area of a worksheet if youll want to print a di�erent area next time?

 
On the file menu point to
print area and then click

set print area.

On the file menu click
print and then click

selection under print
what

On the view menu click
custom views then click

add
All of the above 2

458      How many recent files you can display on File menu at maximum?

  4 6 9 12 3

459      How many steps are there between Start and Finish in AutoContent Wizard?

  3 4 5 6 1

460      How many ways you can save a document?

  3 4 5 6 1

461      How many di�erent positions can you set for drop cap?

  1 2 4 6 2

462      How many characters can be typed in a single cell in Excel?

  256 1024 32000 65535 4

463      How many columns can you insert in a word document in maximum?

  35 45 55 65 2

464      How do you select an entire column?

 
Select Edit > Select >

Column from the menu
Click the column heading

letter

Hold down the shi� key as
you click anywhere in the

column

Hold down the Ctrl key as
you click anywhere in the

column
2

465      How do you print your slides in a handout that includes lines for notes?

 

In the print dialog box
select handout and set

the number of slides per
page to 3

In the print dialog box
select handout and set the
number of slides per page

then select the include
comment page option

In the print dialog box
select note page instead of

handout
All of the above 1

466      How do you insert a row?

 

Right-click the row
heading where you want

to insert the new row
and select Insert from

the shortcut menu

Select the row heading
where you want to insert
the new row and select

Edit >Row from the menu

Select the row heading
where you want to insert
the new row and click the
Insert Row button on the

standard toolbar

All of the above 1



467      How do you delete a column?

 

Select the column heading
you want to delete and
select the Delete Row

button on the standard
toolbar

Select the column heading
you want to delete and

select Insert Delete from
the menu

Select the row heading
you want to delete and
select Edit>Delete from

the menu

Right click the column
heading you want to

delet and select delete
from the shortcut menu

4

468
     How do you create speaker note pages that show the slides related notes and your company logo on each
page?

 
Edit the notes master

and add your company
logy

Edit the slide master and
insert your company logo

and notes pane

Edit the handout master
to include your company

logo and one slide per
page with additional note

space

All of the above 1

469      How do you change column width to fit the contents?

 
Single-click the boundary
to the le� to the column

heading

Double click the
boundary to the right of

the column heading

Press Alt and single click
anywhere in the column

All of the above 2

470
     How do you add degrees of transparency to shapes such as arrows so that the slide background shows
though?

 
Use style 4 button on the

drawing toolbar

Use the Set Transparent
Color button on the

Picture toolbar

Use the Transparency
slider in the Format

AutoShapes dialog box
All of the above 3

471      How can you update the values of formula cells if Auto Calculate mode of Excel is disabled?

  F8 F9 F10 F11 2

472      How can you show or hide the gridlines in Excel Worksheet?

 

Go to Tools >> Options >>
View tab and mark or
remove the check box

named Gridline

Click Gridline tool on
Forms toolbar

Both of above None of the above 3

473      How can you remove tab stop markers from ruler?

 
Double click the tab

marker and choose Clear
All

Drag the tab stop marker
out of the ruler

Right click the tab stop
marker and choose

remove
All of the above 2

474      How can you remove borders applied in cells?

 
Choose None on Border

tab of Format cells

Open the list on Border
tool in Formatting toolbar
then choose first tool (no

border)

Both of above None of the above 3

475      How can you quickly reinstate a deleted footer placeholder in master view?

  Create a new slide master
Re-apply the footer

placeholder
Re-apply the slide layout All of the above 2

476      How can you print three copies of a workbook?

 

Select File>Properties
form the menu and type 3
in the Copies to print text

box.

Select File >Print from
the menu and type 3 in
the Number of copies

text box

Click the Print button on
the standard toolbar to

print the document then
take it to Kinko?s and have

2 more copies made

Press Ctrl+P+3 2

477      How can you get your photo album slide show to play continuously?

 
Use random slide

transition
Launch an online

broadcast
Loop continuously All of the above 3

478      How can you make the selected character superscripted?

  Ctrl + = Ctrl + Shi� + = Alt + Ctrl + Shi� + = None of the above 2

479      How can you increase the font size of selected text by one point every time?



  By pressing Ctrl + ] By pressing Ctrl + [ By pressing Ctrl + } By pressing Ctrl + { 1

480      How can you find specific information in a list?

 
Select Tools > Finder from

the menu
Click the Find button on

the standard toolbar
Select Insert > Find from

the menu

Select Data > Form from
the menu to open the
Data Form dialog box
and click the Criteria

button

4

481      How can you disable extended selection mode?

  Press F8 again to disable Press Del to disable Press Esc to disable Press Enter to disable 3

482      How can you delete a record?

 
Delete the column from

the worksheet

Select Data > Form from
the menu to open the
Data Form dialog box

find the record and Click
the Delete button

Select Data > Delete
Record from the menu

Click the Delete button on
the Standard toolbar

2

483      How are data organized in a spreadsheet?

  Lines and spaces Layers and planes Rows and columns Height and width 4

484      How can you access the font size tool on formatting toolbar?

  Ctrl + S Ctrl + Shi� + S Ctrl + P Ctrl + Shi� + P 4

485      How can you apply exactly the same formatting you did to another text?

 
Copy the text and paste in
new location. Then type

the new text again.

Copy the text and click on
Paste Special tool on new

place

Select the text then click
on Format Painter and

select the new text
All of the above 3

486      How can you break the current column and start a new column immediately?

  Press Ctrl + Shi� + Enter Press Alt + Enter Press Ctrl + Enter Press Alt + Shi� + Enter 1

487      How can you create a uniform appearance by adding a background image to all slides?

  Create a template Edit the slide master Use the autocorrect wizard All of the above 2

488      Gridlines . . . . . .

 
May be turned o� for

display but turned on for
printing

May be turned on or o� for
printing

The be turned o� for
display and printing

A B and C 4

489      What happens if you mark on Hidden check box of Font dialog box a�er you select some text?

 

The text is deleted from
document and you need

to bring from Recycle Bin if
required again.

The text is hidden and
you need to bring it by

removing the check box
if needed again

The text is deleted and
cannot be returned back

The text is hidden and
cannot be returned back

2

490      From which menu you can access Picture Test Box Chart etc?

  File Edit Insert View 3

491      From which menu you can insert Header and Footer?

  Insert Menu View Menu Format Menu Tools Menu 2

492      Getting data from a cell located in a di�erent sheet is called?

  Accessing Referencing Updating Functioning 2

493      Good design determines . . . . . .

  Credibility Readability First impression All of the above 4

494      You need the insert function dialog box. How do you get it?

 
Right click a cell and then

click insert
Click the insert menu

and then click function
Type = in a cell All of the above 2



495      Formatting a cell in Currency you can specify . . . . . .

  Decimal Places Currency Symbol Both of above None of the above 3

496      Formatting a cell in Number format you cant set . . . . . .

  Decimal Places Use 1000 separator Negative numbers Currency Symbol 4

497      Format painter is used . . . . . .

 
To paint pretty picutures

on your slides

To copy formatting from
one object or piece of
text and then apply it

elsewhere

To change the background
color of your slides

To paint pretty pictures on
background of slides

2

498      Excel uniquely identifies cells within a worksheet with a cell name

  Cell names
Column numbers and row

letters
Column letters and row

numbers
Cell locator coordinates 3

499
     Excel worksheet cells work very similarly to what common element of the windows graphical user
interface . . . . . .

  Option buttons List boxes Text boxes Combo boxes 3

500      Except for the . . . . . . function a formula with a logical function shows the word TRUE or FALSE as a result.

  IF AND OR NOT 1

501      Excel is a . . . . . .

  Graphic Program None of these Word Processor A Spreadsheet 4

502      Excel probably considers the cell entry January 1 2000 to be a

  Label Value Formula Text String 2

503      Ellipse Motion is a predefined . . . . . .

  Design Template Color Scheme Animation Scheme None of the above 3

504      Excel files have a default extension of . . . . . .

  xls xlw wk1 123 1

505      DropCap means . . . . . .

  All Caps Small Caps Title case None of the above 4

506
     Each excel file is a workbook that contains di�erent sheets. Which of the following can not be a sheet in
workbook?

  Work sheet Chart sheet Module sheet Data sheet 4

507      Each excel file is called a workbook because . . . . . .

 
It can contain text and

data
It can be modified

It can contain many
sheets including

worksheets and chart
sheets

You have to work hard to
create it

3

508      Edit >> Delete command

 
Deletes the content of a

cell
Deletes Formats of cell

Deletes the comment of
cell

Deletes selected cells 4

509      Documentation should include . . . . . .

 
Destination and users of

the output data
Source of input data

Information on the
purpose of the workbook

All of the above 4

510      Data can be arranged in a worksheet in a easy to understand manner using . . . . . .

  Auto Formatting Applying Styles Changing Fonts All of the above 4

511      Data marker on a chart are linked to data points in a worksheet therefore . . . . . .



 
You can automatically

apply formatting to a data
series

You can change the
position of a data marker

and automatically
change the data point
value in the worksheet

You can change a data
print value and

automatically are draw
the chart

A and B 2

512
     Comments on a presentation can record who wrote them and when they were added. Whats the automatic
way in PowerPoint 2002?

  Use online collaboration Use comments Use the notes page All of the above 2

513      Comments put in cells are called . . . . . .

  Smart tip Cell tip Web tip So� tip 2

514      Concatenation of text can be done using . . . . . .

  Apostrophe () Exclamation (!) Hash (#) Ampersand (&) 4

515      Ctrl + D shortcut key in Excel will . . . . . .

  Open the font dialog box
Apply double underline for

the active cell
Fill down in the selection None of the above 3

516      Charts tips can . . . . . .

 
Show the formatting of a

data label
Show the name of a data

series
Show the value of data

point
B and C 4

517      Columns dialog box can be opened from . . . . . .

 
Format menu Columns

submenu
Double click on column

space in ruler
Press Alt + O + C All of the above 4

518      Comments can be added to cells using . . . . . .

  Edit > Comments Insert > Comments File > Comments View > Comments 2

519      Changing the appearance of a document is called . . . . . .

  Proofing Editing Formatting All of the above 3

520      Background color or e�ects applied on a document is not visible in . . . . . .

  Web Layout View Print Layout View Reading View Print Preview 4

521      Block arrows stars and banners and callouts are all examples of . . . . . .

 
Di�erent types of childrens

building blocks
Auto Shape categories

Clip art categories located
in the Microso� Clip

Gallery

More technical terms that I
dont understand

2

522      Bold Italic Regular are known as . . . . . .

  Font Styles Font E�ects Word Art Text E�ects 1

523      Borders can be applied to . . . . . .

  Cells Paragraph Text All of the above 4

524      By default Excel provides 3 worksheets. You need only two of them how will you delete the third one?

 

Right click on Sheet Tab
of third sheet and choose
Delete from the context

menu

Click on Sheet 3 and from
Edit menu choose Delete

Both of above None of the above 1

525      By default the cell pointer moves down when you press Enter. From where can you change this setting?

 
Tools >> Options >> View

tab
Tools >> Options >>

Calculation tab
Tools >> Options >> Edit

tab
Tools >> Options >>

Transition tab
3

526      Can you set 0.5 inch le� indentation for a cell in Excel?

 
Excel does not have
indentation feature

You can specify
indentation only if you

turn the rulers on

Indentation can be set
from Format Cells dialog

box

The indentation can be
specified only when

printing
3



527      Any and every command can be found on the

  Drawing Toolbar Formatting Toolbar Standard Toolbar Menu Bar 4

528      Auto clip art is a feature that

 
Automatically places clip
art in your presentation

Scans your presentation
for incorrect spelling of

words on each slide

Scans your presentation
for incorrect spelling in

word art objects
All of the above 4

529      AutoCorrect was originally designed to replace . . . . . . words as you type.

  Short Repetitive Grammatically Incorrect Misspelled None of the above 3

530      Animation schemes can be applied to . . . . . . in the presentation.

  All Slides Selected Slides Current Slide All of the above 4

531      An excel workbook is a collection of

  Workbooks Worksheets Charts Worksheets and charts 4

532
     An organization has a president vice president managers and supervisors. On what level of an organization
chart are the vice presidents?

  Fourth level Third level Second level First level 3

533      A�er typing header text how can you quickly enter footer text?

 
Press PageDown key and

type the text for footer

Click on Switch between
Heder & Footer then type

the text
Both of above None of the above 2

534      All worksheet formula

  Manipulate values Manipulate labels Return a formula result Use the addition operator 3

535
     A�er moving a clip art image to a particular location on the slide you can immediately reverse the action
by . . . . . .

 
Clicking the not do move
object command on the

edit menu

Clicking on the undo
button

Clicking on redo button All of the above 2

536      A worksheet range is a . . . . . .

 
A command used for data

modeling
A range of values such as

from 23 to 234
A group of cells A group of worksheets 3

537      A�er choosing a predefine template . . . . . . option has to be chosen to change a background color.

  Design Template Color Scheme Animation Scheme Color E�ects 2

538      A worksheet can have a maximum of . . . . . . Number of rows.

  256 1024 32000 65535 4

539      A word processor would most likely be used to . . . . . .

 
Keep an account of money

spent
Do a computer search in

media center
Maintain an inventory Type a biography 4

540
     A user wishes to remove a spreadsheet from a workbook. Which is the correct sequence of events that will
do this?

 
Go to File-Save As > Save

As Type > Excel worksheet

Right click on the
spreadsheet tab and

select DELETE

Right click on the
spreadsheet and select
Insert > Entire Column

None of the above 2

541      A typical worksheet has . . . . . . Number of columns.

  128 256 512 1024 2

542
     A screen element of MS Word that is usually located below the title bar that provides categorized options is
. . . . . .

  Menu Bar Tool Bar Status Bar All of the above 1

543      A numeric value can be treated as a label value if it precedes with . . . . . .

  Apostrophe () Exclamation (!) Hash (#) Ampersand (&) 1



544      A new presentation can be created from . . . . . .

  Blank Presentation
From Existing
Presentation

From Design Template All of the above 4

545      A file which contains readymade styles that can be used for a presentations is called . . . . . .

  Auto Style Template Wizard Pre-formatting 2

546      A function inside another function is called a . . . . . . function.

  Nested Round Sum Text 1

547      A data map is helpful . . . . . .

 
When you have too much

data to chart
To show a geographic

distribution of data
To compare data points

To show changes in data
over time

2

548      A feature of MS Word that saves the document automatically a�er certain interval is available on . . . . . .

 
Save tab on Options

dialog box
Save As dialog box Both of above None of the above 1

549      A circular reference is . . . . . .

  Geometric modeling tool
A cell that points to a

drawing object

A formula that either
directly or indirectly

depends on itself
Always Erroneous 3

550      A character that is raised and smaller above the baseline is known as . . . . . .

  Outlined Raised Superscript Subscript 3

551      A chart can be put as a part of the presentation using . . . . . .

  Insert -> Chart
Insert -> Pictures ->

Chart
Edit -> Chart View -> Chart 2

552      A cell is defined as . . . . . .

 
The intersection of a

column and a row
An input box A rectangular marker All of the above 1

553      Which of the following is an example for automatic text formatting?

  Underlining hyperlink Adjusting extra space
Replacing two - with

hyphens
All of the above 4

554
     A bookmark is an item or location in document that you identify as a name for future reference. Which of
the following task is accomplished by using bookmarks?

 
To add anchors in web

page
To mark the ending of a
paragraph of document

To quickly jump to
specific location in

document

To add hyperlinks in
webpage

3

555      . . . . . . controls all the main slide control tasks for your presentation.

  Task Pane Task Bar Control Panel None of the above 1

556       If you select Insert >> Picture >> From File

 
You can insert pictures

and clipArts
You can insert clipArts only

You can insert pictures
only

None of the above 3

557      Which of the following is a correct order of precedence in a formula calculation?

 
Multiplication and division
exponential positive and

negative value

Multiplication and division
positive and negative
values addition and

subtraction

Addition and subtraction
positive and negative
values exponentiation

None of the above 4


